What's going on here then? Ongoing camera glitch

Using a mavic pro with android and latest version of dji go. So the camera controls on the phone screen freeze…but on the rc controller they work fine. Can’t playback images on the drone sd card through the phone (can’t go into playback mode at all) but images are recorded fine on the sd. Can’t control camera settings on the phone. Tried two different sd cards, freshly formatted, no difference. Also, phone is unable to version check the aircraft firmware for update. Any ideas??

I flew my MP with my android phone the other day and noticed that the photos didn’t show through the app. Videos were there though. Wasn’t sure if it was just a one off. I’m using older version of GO4.

Would be interested in hearing thoughts on this.

i dont tend to use my phone anymore as i have the bt300 glasses instead. may give it a try with phone and see whats up tho.

This will be some kind of issue with Go4 on your phone.

Tried rolling back a version or two?

I have had something similar on an android tablet. I found that there were other apps running in the background affecting the ability of Go 4 to respond. The video stream to your phone uses up processing power as well and could be a factor, Check the version of Android and make sure its up to date.
I also had this issue with the inspire 1 with and Ipad 2 mini , couldn’t handle all the demands . Had to buy a Android Lenovo Tab 4+ (octo processor at 2 Ghz)

Sounds likely as this stayed happening with latest update…how do I roll back though…?

By uninstalling, downloading the .apk you want to use from : https://www.apkmirror.com/apk/dji-technology-co-ltd/dji-go-4/ : and installing from that.

1 Like

Dodgy cable?


With a shot! It’s turning out to be intermittent, so it does sound like it…weird it would only affect camera functions though…

1 Like