When your drone doesn't do what you expected - Air2S and RC Controller

I am still early in the process of getting used to my new RC Controller (not Pro) and on the whole I am pretty pleased with it. A number of folks here have shared that they don’t use the screen recorder function, but I got to say, I find it quite useful. It works as a secondary monitor of things I may not understand when something untoward happens.

There are currently two things that are concerning me about the RC Controller.

The first was a big discrepancy between what I asked the App to do by way of a Return To Home height, and what the drone actually did.

Today, just for the hell of it, I check on the RTH functionality. I checked this was working when the RC Controller first arrived, but it was damned cold so I thought I would check it … cause what else are you going to do when its that cold? :cold_face:

My default RTH height is 150ft. I have watched the drone previously when RTH is activated and it always starts by increasing (or decreasing) it’s altitude to match these settings before starting home. RTH=150 feet.

When I activated RTH today the drone just started on it’s way home and landed. I checked the settings afterward and RTH was definitely set to 150ft.

I was also pretty close to my landing position and the drone was already at 105ft, so I am a little confused about why it disobeyed.

Here’s the RC Controller On-Board recording of the controls and settings.

The second concern has to do, probably, with correct process when changing batteries.

I tend to land my Air2S, turn it off and then change to a fresh battery, all with the RC Controller still running. Usually it just detects and reconnects to my drone and off we go again.

As policy I ALWAYS wait a while so the drone can report its home location and then hover for a few minutes before doing anything purposeful.

I had noticed a couple of strange entries in my AIRDATA logs that I was trying to get my head around, here’s an example;

Uplink Error

Today I changed batteries using the same process, but when I issued the climb command, nothing happened. The drone just sat there, props activated and rotating.

I tried to lift off a couple more times with the same result. Drone, sat on the ground with its blades rotating.

On a gut instinct I had the app go back to the start screen, the one before you click on the “Go Fly” button. Then I connected to the drone and tried again. This time the drone raised off the ground and behaved as expected.

I performed some very cautious nearby maneuvers before deciding it was safe to carry on with my flights.

This was a completely new behavior and was a tad unsettling. :worried:

Has anyone else experienced this with their drone and the RC Controller while changing batteries?

Alternatively, can anyone shed light on the RTH height question?

Is this likely to be an issue related to cold weather. It was Minus 2 where I was flying.

Thanks everyone!

Pretty sure that’s normal behaviour for the distance your were from home point.

It won’t ascend unless it’s at least 50m away.

1 Like

20m I think it just lands too


RTH is working as it should

1 Like

Excellent, thanks for the feedback (reassurance) :vulcan_salute:

1 Like

I always turn off my controller when I change a battery then when the new battery is in I restart the controller and wait while it starts the app doesn’t take much longer and it’s all a fresh start , much the same principle as reformatting your sd card after you have downloaded you pics , I could just put it back and carry on but by clearing it then it’s a fresh start with no worries, but that’s just how I do it

1 Like

A new log is created each time the drone is turned on, and a flight log when you lift off, this also stops when landing and powering off. By turning the controller off and back on, apart from possibly saving some battery life it won’t actually be of benefit.

I might consider doing this if it didn’t take so damned long for the RC Controller to actually boot up. Also, the controller keeps the satellite count stable while I change the battery on the drone, rather than having to require them all over again.

That being said, if I saw a direct link between this issue and restarting the controller as part of the process, then obviously, I would follow that process.

There are just more strange occurrences at this point with the RC Controller than I ever saw with the N1 controller (not withstanding that we have already resolved the RTH height behavior as being entirely normal).

The satellite count is done by the drone, it’s because of the hot start you still have a good count

I suspect your issue could be a bug in the software, it maybe a one off occurrence

Test it again and see if you can replicate the issue

If so
Contact DJI to report it

I will do that, absolutely. Thanks.

1 Like

Let us know how you get on :+1:t2: