Bad video feed on Mavic Air 2

Hi all
I hate to use my first post with a problem but hopefully someone can shed some light on the problems I am having with my Mavic Air 2 video transmission.
Bought it new only 7.5 weeks ago (has had no crashes, hard landings or rough treatment) and it initially performed perfectly well with no problems until a week ago when the video feed started to freeze up showing pink/purple bands flashing on screen. For some reason this cleared its self and performed fine for several more flights but has now come back again permanently. Here is a Vimeo link showing the problem. Password=mavicair2 https://vimeo.com/556912845
I’m using an I-pad air 1st generation (16gb with 6gb available) that may well be low on processing power but has worked well for the Mavic air 2 up until now and is fine with my Mini 2, (as well as an Inspire 1 for the past 5 years). Although I do get a CP fully loaded warning at times but don’t think this would be the sole cause of my issue. The problem still exists when using a brand-new 8th generation I-pad so it would seem unlikely to be the cause.
I’ve found the video transmission degrades more when given more work to do such as 4k high fps and improves slightly in 1080 with a lower fps (still laggy but with no pink/purple flashing bands).
The signal strength and satellite count is fine and the drone responds as it should to the controls. Uploaded flight logs to Airdata UAV have not flagged up any issues, although I do occasionally get a ‘slow SD card’ notice which is strange as all the cards are on the DJI list.
I can fly my Mini 2 in the same area at 4k 30 fps, or any other setting, with no issues.
Things I have tried so far that have made no difference………
Tried a second controller, from a Mini 2.
Changed usb cable, DJI supplied and 2 apple ones.
Tried 4 different micro sd cards (all DJI recommended types)
Transmission setting tried on smooth and HD.
Refreshed firmware on drone and controller.
Sensors, compass, IMU and gimbal re-calibrated.
Deleted and re installed DJI Fly app.
Cleared every cache I could find. I-pad set to airplane mode with no other programs running in the back ground.
Tested on a brand new I-pad.
Time to send it back to DJI or not? Thanks in advance for any help.
Kevin

Welcome to Grey Arrows Kevin @Straze and thank you for the amount of detail, exactly what we need to help diagnose a problem :smiley:

What an interesting problem…

Both drones use the DJI Fly app.

Both drones are OcuSync 2.

So we can rule that out :thinking:

Is it possible that one drone places a higher demand on the app/device than the other? I’m not sure how that’d be possible, but hey… :man_shrugging:t2:

Looking at the list of all the things you’ve tried, the one that jumped out at me as missing was “a different tablet/phone”.

That’d be my next step.

To be honest, I’m amazed the DJI Fly app works at all, it’s a power-hungry beast and the original 1st gen iPad Air was launched waayyyyyyy back in 2013 :scream: That’s an absolute eternity as far as DJI bloatware apps are concerned :blush:

Id’ try another device before doing anything else. A device that you know is more than capable of running it smoothly.

Also, perhaps related to the timings of it all going Pete Tong.

We’ve seen a bunch of reports here of the latest Fly v1.4.2 app on Android tipping some devices over the edge. Where they have been running every version of Fly just fine, the new v1.4.1 and v1.4.2 that came out last week are now failing on some devices.

I know you’re Apple, but the same thing might be happening?

Details: Jittery & Jumpy Recordings - Mini 2 any advice? - #28 by OldSoulBoy

And more issues reported here: DJI Fly - App updates and download links - #303 by scottydog

There is some stuff posted by Tech drone media about problems with these latest updates for iOS I didn’t watch them as I am mostly android but might be worth a look Henric who runs the channel is very honest guy who normally finds some interesting stuff. This last 2 updates for the fly app totally stuffed me but since I rolled back to original it’s been fine . Also as a ps if you are using a iPad 1st gen this maybe why you are hitting a similar problem to some Android users. If you roll back the version go back to V 1.4.0

1 Like

Thanks for the advice all.
I will find a willing friend with a posh new phone as my old steam driven android brick wont take the Fly app.
Looked into downgrading to v1.4.0 but it looks like this cant be done with IOS but the search is still on.
Shame this has happened as I was so pleased with the MA2 performance and quality of footage.
I have contacted DJI and hope to get to the bottom of this soon.
Thanks again.
Kevin

DJI might not be much help, they’ll just refer you to the list of compatible devices they have on their web site :slight_smile:

Which is:

Compatible with iPhone 12 Pro Max,iPhone 12 Pro,iPhone 12,iPhone 12 mini,iPhone 11 Pro Max,iPhone 11 Pro,iPhone 11,iPhone XS Max,iPhone XS,iPhone XR,iPhone X,iPhone 8 Plus,iPhone 8,iPhone 7 Plus,iPhone 7,iPhone 6s Plus,iPhone 6s,iPhone 6 Plus,iPhone 6,iPad Pro(9.7-inch),iPad air2(9.7-inch),iPad mini4(8-inch),iPad Pro(10.5-inch),iPad Pro 2018(11-inch),iPad Pro (12.9-inch)

You can try an old v1.1.10 if you like?

Be sure to remove the current Fly app first.

Then scan this, with the camera on your iPad:

Can’t promise it’ll work :blush:

Thankyou.
I did try this but failed to roll back.
Having done further tests and trials the camera feed is now dropping out completely and will only return briefly if the AC is turned off and back on again. I’m quite sure there’s a fault within the AC, especially as the same setup works well for my Mini 2.
Waiting for DJI to come back with a course of action now. How quick are they sorting out faulty stuff nowadays?
Oh! and due to having planned drone projects coming up and an expected long delay from DJI I’ve accidentally bought an Air2s! LOL
So far well pleased with it (although I did say the same with the Air 2) fingers crossed.
Regards
Kevin

Quick update…sent off to Holland today for repair/replacement. I will let you know how things end up.

Drone collected Tuesday am
Received in Holland Wednesday by 11am
Repaired Thursday (new camera module under guarantee)
On it’s way back Friday
Now that’s what you call good service.

Excellent news!

Thanks for the updates too, it’s nice to hear positive stories about a company for a change :slight_smile: