DJI mini 2 not binding

I have just got a mini 2 from eBay in great condition flys okay. It is up to date on firmware. I keep getting not binded for the fly away function? Click the link get taken to the terms screen, click next then error msg air frame not latest firmware. Is this because I haven’t purchased the care package?

Have you done the long press on the power button on the drone to make it bind? If not power up the controller and drone then press and hold the DRONE power button until it squawks​:flushed: it should then bind​:+1::wink::sunglasses:

1 Like

@Agger Not yet will give it a go


I don’t have the care package and it let me bind. Might need to contact DJI support for advice, could still be bound to previous owner’s account.


Are you talking about in the App under your profile where you bind it to an email address?

I think @Agger is talking about binding drone and controller

1 Like

Sorry if the photos are in the wrong order.
I have updated to the latest firmware but it won’t bind as it tells me update it. I have re flashed /refresh the firmware still nothing. Can’t contact DJI until Monday when the support line is open🙁

Any email address in here?

Open app, Profile, device managemrnt


If the drone takes off and can fly it’s bound to the controller

It sounds like the previous owner had care refresh which included fly away

To activate this you have to bind the bound controller to your account but if you haven’t got care refresh you can’t

Check under the value added service that’s where you bind it to the account

@FFf no mine is blank. @Sparkyws It fly’s ok but I don’t have care protection, I was thinking it was this.

I’ve not got refresh and it has allowed me to bind mine.

1 Like

Did you try what I said above? Did it squawk? Care refresh has nothing to do with it


you’ve had a flyaway and / or lost your drone, in which case you will still be able to fly a new compatible drone but you won’t be covered by Care Refresh unless you went through the replacement process with DJI :+1:

Let us know about the “squawk” as it helps others :+1::wink::sunglasses:

DJI’s own terminology doesn’t help in situations like this.

They have the “remote controller”, the physical thing in your hands which has a serial number and they have the “flight controller” which is a module inside the drone itself which has a different serial number.

Shortening either of those to just “controller” gets everyone confused :blush:



Where I am at so far.
Drone flys as it should up down records video RTH function all works as should, bearing in mind this is my first drone so haven’t seen anything odd.
Reset the controller with the drone. No change.
Used dji assistant 2 (consumer drone) to reinstall or down grade firmware, can only refresh existing, won’t give option for old firmware. Did this still no change.
Deleted app from phone reinstalled. Still no change.
Created a new account on DJI so fresh user. still no change
Have put the same question on the DJI forum, no answers yet.
Can’t contact DJI support via live chat until Monday to ask them.
Still get the same msg firmware not up to date? Clicked both updates and they say up to date, have checked online and this is the current version’s.

Just going to wait for Monday and see what DJI say if anything my not help never used the support before.

Thanks for the advice will update when I have more information.


Have you a screenshot of this message?

Version 01.05.0000 cant be rolled back :scream:


Just below the next icon

But why are you trying to enable the flyaway option in carefresh if you don’t have it?

@Sparkyws every time I turn on I get this error. As others have said they don’t have care protection and it works? I am more concerned it is saying the drone isn’t updated? I will not be getting the protection as it isn’t worth it as so many are being sold on eBay as most mini 2 users have or are upgrading to mini 3.
If DJI come back and say nothing can be done unless you buy the protection I will just have to live with it.
If this is the case my next drone will more than likely not be DJI.

You Cant buy the care refresh for used drones, its only for new purchases and can only be used for 2 years max

I suspect this drone already has the care refresh but is registered to another user

DJI can sort it, the firmware error is a mistake I think