GO4 app won't open on Tab 4 device

I am new mate so scared even of the dji go app ! still wont open on the tab 4 ?
It would be good if reliable as you would have control of the full flight before you started.

1 Like

Right so in order to get your tab 4 working have you tried clearing the tablets cache and then restarting the device

Hi mate, yes I have and uninstalled and re installed the app and restarted etc


just tried again and it wont even open

OK what tablet is it

I’m lost.

1 Like

Tab 4

That was a mistake and I forgot to delete that haha!

Do you have 3 gigabytes of ram?

Hi sorry for delay, yes, the guy I bought it off used the tablet to show me it working, he reset it as so it was no longer his and I downloaded it again and just wont open on it.


Have your tried switching off all wireless options first, before launching the app @dazer2000 ?

It worked here:

1 Like

I will give that a go.
Sorry for my slow reply guys we are in London on a training course back home sunday.

Tried without wi fi and still the same, on app store it says “not optimized for this device” ? dji go says pre 4 ?

Try Litchi is a better app than the Go4 .just my opinion.

Ok Ill try it mate thank you.

Or try an older version of GO4

(Although my main flight controller Of choice is also Litchi)

Any ideas where I can get older version from ?

I have downloaded a version from 2018 and it works ! I am not superb with computers but seems to open as it should.
Does Litchi give you good reliability ?