Help with the new (to me) machine, please

The “used maybe 3 times” Nazgul I got on ebay just arrived.

So far I’ve had a couple of failed attempts to bind to it, but I had similar issues with the Croc and ended up having to reflash the receiver. I’ll look into this a bit further, it’s an R-XSR.

Meanwhile, it’s very noisy and twitchy. Is this normal?

The motors all function as expected when I plug it into BetaFlight.

And, of course, while all the pictures on the listing looked good, in the flesh it looks like it’s ended up in a muddy puddle at some point.

I’d just about given up on buying from ebay precisely because of this kind of uncertainty. Maybe I should have held firm with that. :slight_smile:


Thats the no rx beacon I think. Its normal


OK. I’ll hold off panicking until I’ve had a proper stab at getting it bound. It would be nice if the process was a bit easier.

Cheers, Karl

Buy into TBS Crossfire or Tracer and this will become true and you’ll never worry about failsafe again :ok_hand:t2:

Also the bind process is super easy put radio in bind mode plug battery into the quad press the bind button on the rx job done :+1:t2:

Also brand new RXs come in bind mode so you don’t even need to press the button lol just put the radio into bind mode before powering up the new rx and it will bind automatically :slightly_smiling_face:


All that he says :point_up: is true

1 Like

That’s all well and good, but I’m not going to spend yet more money converting everything to Crossfire when the kit I have should work and I’m still very short on time in the air. :rofl: :cry:

Correct - can be changed in betaflight

1 Like

Alright. I’ll just be wrestling with binding then. Probably need to check the Type/Subtype on OpenTX.

What rx is in it?

Looks like an R-XSR, exactly like the one in Airlessmean’s photos.

Thats just the “no rx” beeper i wouldnt turn it off tbh its a handy feature if the worst occurs.

Bit strange it wont bind generally a good idea is to just hold down the bind button while you plug the battery in. Kinda get what you pay for with frsky unfortunately

Thanks. I had similar issues with the GEPRC Croc Baby which came with an XM+, but after discovering that they shipped with the latest firmware that isn’t compatible with OpenTX (or the version I am running that works with my Nanohawk) I reflashed that to an earlier version and got it to bind OK.

So I figured this may be a similar issue. Also looking at the product page on HobbyRC there’s this:

**** PLEASE NOTE, New Stock now ships with ACCST V2.1 (EU LBT) Firmware on. Its far more likely you want ACCST V1 EU LBT firmware so if in doubt, please choose a different firmware option or contact us to discuss before purchasing ****

So I’ve just downloaded RXSR_LBT_ACCST_191112.frk and flashed it. Still not having much luck.

On straight power up I get solid blue, which I understand means SBUS mode, and a flashing red, which means not bound.

On powering up with the button held down I get solid blue green and red.

I have the TX12 set to FrSky X/D16 and I’m choosing the ‘Ch1-8 Telem OFF’ bind option, as this is what worked for the Croc, if I recall correctly.

I’ve messed with the FreqTune setting a bit, as I have seen some sources suggest that this might help.
Still no luck.

Sounds like its using frskys new protocol, you may not be compatible with that at the moment.

I’ve just flashed it to v1.9.1 as I understand it’s v2.x that’s incompatible.

I suppose the Croc’s currently out of action so I could try transferring the XM+ across to see if that works.

Well, I’ve just swapped the XM+ from the Croc onto it, which should already be bound to my controller, and it’s still not playing. I haven’t yet put it back on the Croc to double check. Decided I’d rather go to the pub.

If I switch the XM+ back to the Croc and it works it’ll be time to contact the seller.


Double check your ports tab and config tab

What uart is the receiver connected to Jez?

Thanks, guys. These are questions for tomorrow when it’s raining.

Right now it’s time for beer in the sun and maybe some light gardening. :sunglasses: :beers:

1 Like

Monsoon outside right now in my neck of the woods :rofl:

It’s lovely down here mate and I’m banking on getting out flying tomorrow morning too :crossed_fingers:t2: Probably shitty in the afternoon though lol