Litchi - No Flight Logs

I’ve managed a few successful flights using Litchi missions (and one that was almost very unsuccessful … :stuck_out_tongue: ) … but I’m not getting any Flight Logs saved where I believe they should be (Android: LitchiApp\FlightLogs) … indeed, that folder doesn’t even exist.
Unintstalled/reinstalled - no difference.
Anyone any thoughts?
(The “missions” folder isn’t “empty” … it has all the relevant subfolders for that all to work OK.)


I found this on Mike Singer’s site:

Do you have this issue perhaps? And need to use the SD Refresh tool to reveal the folder?

For me, even the folder isn’t there … so not much chance of the files in it being there.
The file browser I use has hidden files set to visible … so not a hidden folder.

Aslo - zero response from Litchi. I expect that from free apps, though they usually perform well, but when one’s paid money …. really annoys me!
Emailed and forum. Nothing.

1 Like

If the folder isn’t there, can you try creating it Dave?

It’ll either tell you it can’t (because it already exists) or it’ll create it without an issue - and the future flights may be able to save to that folder?

Perhaps it can’t log, simply because the folder isn’t there?

I'm only guessing now!

Been there, tried that too.
Android, I’m told, will automatically add a path when an app tries to write to one that doesn’t exist.

Looked all through Litchi for a setting that does/doesn’t log … but can’t find one. Even though that’s what it feels like.

Hmmmm :thinking:

So it lets you manually create the folder?

In Windows? Or in Android?

Of course, I’ve seen reference to the folder in various case arrangements, but not sure that should matter. It should be creating a folder it needs that’s not there. I get the impression that it’s not even trying.

Well - bugger me!!!

After all this time … solved!!

AirData’s site, more than 6 months later, is still saying :

The files are stored in the “LitchiApp/flightlogs” folder and look like this:


But there’s nothing in that location!!


HOWEVER - in prep for doing a Factory Reset on my Drone-Phone, I thought I should poke about in the DJI folder to see what I want to backup, and restore afterwards.

So - what’s this “com.aryuthere.visionplus” folder I see, all about?

Turns out THIS is where Litchi is ACTUALLY saving the logs …

\Internal storage\DJI\com.aryuthere.visionplus\FlightRecord


… and, as you can see, the folder is “FlightRecords” (not “flightlogs”) and the .csv that I searched for and never found are in fact .txt !!!

1 Like


That’s a legacy folder from their beta versions, which I guess didn’t clean itself up properly after installing a non-beta version?

I wonder if the settings from a beta were just carried across to a non-beta version that you installed?

Nope - where it is above is where it is on all three of my phones … and I only installed it (as an emergency backup) on my main Phone a couple of weeks ago.

And I’ve never been a Litchi “tester”.

Drone Harmony (installed - never used) is also a sub-folder of DJI folder.

A beta version you mean?

I blame Wiley :grimacing:

Nope - NEVER had a Beta Litchi on any device.

Another train of thought…

I wonder if that path is really old path? If you’ve been using Litchi for years, I wonder if once upon a time that was the genuine / original path and that they have changed it on newer versions? Hence their web site only showing the ‘modern’ path? :thinking:

Let’s face it … a lot of differences from what AirData say should be the case …

Folder in a different location
Main Folder a different name
Flight Log folder a different name
Files .txt not .csv


But my latest installation (new phone - never been beta - only installed a couple of weeks ago) ISN’T the one on that website!

The good news is I discovered before I did a factory reset and lost over 6 months of Litchi data.