Mavic 2 pro camera blackout

Hi all,

I’m flying a Mavic 2 Pro commercially for TV broadcast in the UK, but every now and then the image is black at take off.

I’ve mostly noticed this in flying zones that DJI gets a bit nervous about, even though I self certify that I’m authorised to fly, and have the required permissions from Air Traffic Control. However, it MAY have happened at other times as well - I’m not sure.

Couple of full resets on the drone and the controller and the image returns, but does anyone else have this, or know what I’m doing wrong please?


Welcome to Grey Arrows @julesendersby

The gimbal ribbon cable would be my first suspect.

You’ve lost me, but it sounds like you mean there’s a loose connection?

I’m sure this could be it, but normally this happens when I’m trying to mess around with the unlocking license…I start with an image, but then it goes while I’m unlocking!!!

I meant the ribbon cable could be damaged, rather than loose. They’re very fragile.

Thanks again - but isn’t it strange that it feels like a glitch when I’m trying to resolve the unlocking feature?

Have you had this issue before? Or heard of it?

Does it happen if you use Litchi?

I’ve had this a couple of times. Changing the frequency from 2.4 to 5.8 or vice versa sorted it.
had you got your phone on when it happened?

No idea what Litchi is, sorry

My phone is on specifically because I need to use it as a hotspot to unlock the area I’m flying in…

It’s an alternative non DJI app to fly your drone with.

Just recently I too have had it on my Smart controller much the same when you do a self unlocking, Ive had to reboot both the Smart Controller and the M2, it still records photos and video but you get a blank screen whilst flying - not good

Can you put it into Aeroplane mode after the unlocking?

Anything we might have seen?

Assuming you aren’t using a Smart Controller, have you tried using a different cable between your controller and phone? I had this a few times when I tried using a (cheap) cable I brought off t’internet. Swapped to a new one, all sorted.

Also, just to clarify - when you say the image is black, do you see anything on the app (like the battery, mini-map, etc) or is the whole screen just black? The cable problem caused the latter.

Edit: Never mind… just saw your other post (DJI Smart Controller - charging issue?) :wink:

1 Like

I don’t know what this is, sorry. I can take off but there’s no image from the camera

Nothing yet, won’t be out for a few more months at the earliest :shushing_face:

You don’t know what Airplane mode is on the phone ?

May be called “Flight mode” on some phones, not to be confused with the “Flight modes” on the Smart Controller which are obviously entirely different :smiley:

I have had the same problem. Just wait for checking for firmware erosion complete then open go fly. Works every time for me if I remember to do it

Sorry, thought you meant within DJI Go 4 app!
I’m using a Smart Controller so no need to activate airplane mode as I’m not using my phone