Mavic mini- no gimbal dial and can't change mode :(

Hi guys

Does anyone have any idea if there’s something wrong, or is it me?!! If it is something wrong, maybe how to fix or if it’s a fault?

Happened a few times when flying that the Mavic mini won’t allow me to change mode and either gets stuck on what it’s on, or just says n/a. No amount of touching the screen or selecting a different mode in settings does anything.

Also, the gimbal dial disappears and no matter what I try, it won’t reappear. Again, tried in settings, reset, touching screen but can’t for the life of me get it back.

Managed to test it a bit today with airplane mode both off and on, but doesn’t seem to make a difference. Recorded the screen to try and show you what I mean

Is this not due to your current altitude @lurch003?

Well, lack-of…

Don’t the flight modes only become available above a certain height? :thinking:

1 Like

I know you’re not trying to use a quick shot mode, but the same principle may well apply:

Oh… You’re kidding me?!! Am I that much of a pleb?!!

Didn’t even consider that, but I know I had no gimbal dial on my last flight and I guess I would’ve been about 15m up when I noticed and tried to get it back

I’ll need to test more when I can have a play with the drone at work to get a bit of height. My neighbours are good but I don’t want to annoy them anymore than I already do!

2 Likes

Let us know how it goes, I’m curious now… :thinking:

2 Likes

Were you in sports mode?

No mate

Tested twice tonight. First time was stuck in c mode, second was no mode at all, just said n/a

Surely you still get the dial in s mode?

is this not like the mavic 2 pro , in that you have to tell it to use multi modes, by default you only get p mode

you should still be able to control the gimbal in all modes, is there not an option to tell the controller what button or dial controls what

This has also happened a couple of times to me. The only thing that seemed to work was to land, turn off both the controller and the mini then power both back up again

1 Like

Not just me then. If it is software related, hopefully it may get resolved in the next update

Were you able to find out?

Not yet, didn’t get a chance at work today.

Interesting that a few others have had similar experiences…

1 Like

Quick non-update

Manged just over 30 mins at the weekend, tested a whole batterys worth low to the ground and then second battery up to 70m and all around but couldn’t lose mode or gimbal no matter what I did !!!

There have been no software updates so I’m still baffled :frowning_face:

When I first had my mini I connected with my Huawei P20 pro and never had issue then my grandson gave me his Samsung s8 to use just for drone, had tons of problem unable to change camera mode, switching flight mode and touch screen sometimes unresponsive so naturally thought my mini was screwed so tried my iPad Pro and everything perfect again so I assumed it was operating system so did not use Samsung, maybe it was all coincidental, maybe try another device or delete app and reinstall, just a thought :+1:

1 Like

A very good thought dude, didn’t even think of that!

Will test it some more with the Google Pixel 2 (hard at the moment not being able to get out to nice open spaces!), I’ve got a spare iPhone 6 at work so will try that too and hopefully come closer to what it might be.

1 Like

Any updates on this one @lurch003? I’m still curious… :thinking:

I’ll be honest, I’ve flown 8 batteries in the last week and nothing, but I’d forgotten to test. Haven’t been in air plane mode as I forgot that too. Every flight has been a dream though, the only negative being my skills, but I’m learning plus been playing around with the different settings since the update.

So I don’t know if it’s airplane mode related, or if something in the update fixed it, but had no mishaps whatsoever (I’m very pleased to report!).

Actually feel quite lucky, was a bit paranoid reading all the reports about fly aways and prop errors but even after a painful misjudged hand landing and accidentally trimming the grass with the props, I’ve had no issues whatsoever. Thankfully!

You been able to fly lately?

I only ever fly in Airplane mode.

Nothing worse than rocking up at a remote location only to then be told some firmware nonsense needs updating or something :man_facepalming:

I’ve created a dedicated shortcut on my phone screen for the Mini - might also be of interest @milkmanchris

When I click that Mavic Mini icon, it does the following for me automatically:

2 Likes