Mini 2/DJI Fly/Galaxy phone

Went out for a walk with the camera and drone today to a local beauty spot and all was fine, well, apart from the amount of people there!!! The screen on my phone became unresponsive, I couldn’t change any manual setting for the camera or video, couldn’t swap between video/camera and in fact couldn’t change any settings at all evern though I can swipe between different on screen menus. The mini2 still flew well, I got good video feedback with no lag, I just couldnt change anything or press any on screen buttons to do anything, or indeed the buttons on the controller. All a bit wierd! I haven’t updated anything but this has only happened since coming back from repair by DJI.
Aircraft Firmware is 01.02.0000
RC Firmware 04.11.0016
App Version 1.4.8
It’s a samsung galaxy A51 which worked fine two weeks ago??? It’s not the best phone on the market but it’s a work phone and has a bigger screen than my S21 which is why I use it.

Any ideas?

I think it may be the version of Fly you are using. I bought my Mini 2 way back around a year ago and had no problems using a Samsung Galaxy A71 until I upgraded Fly to v1.4.8 when I started getting losses of video downlink and regular app crashes. I tried a few things suggested on forums but nothing seemed to work, so I uninstalled v1.4.8 and re-installed v1.4.2 for which fortunately I still had the .apk on the phone. Sorted all the problems and has been very reliable until a couple of days ago when I foolishly thought I’d try v1.5.0! Within minutes of taking off the video link started to go and I was having disconnect messages coming up. I flew straight back visually, uninstalled v1.5.0 and re-installed v1.4.2 and all was perfect again. I did try contacting DJI via their forum about it, but all they said was that the A71 wasn’t on their approved list and suggest that I should buy a new phone. So my suggestion is to try an older version of Fly and it may well solve all your problems! I suspect that DJI have written later versions of the app that exceed the capibilties of some perfectly suitable phones, outside the guidelines for Android apps, but won’t admit it. The sales page for the Mini 2 just says ‘Android 6 or later’ for Fly requirements, it’s only after you buy the drone and go to d/l the app that you get to see the ‘approved’ list.

2 Likes

Thanks for that, as it happens I rolled back to 1.4.8 from the latest frankenstein version that auto installed, both have their problems. So I will give 1.4.2 a go. The video still records fine to sd, it’s just a little unnerving loosing the video feed even though the flight controls still work.

The aircraft firmware is old, the latest is v01.03.0000

Delete the fly app and go back to 1.4.2 or even 1.4.0

be careful of the app auto-updating, turn it off in the settings

Some good reading here

I’m wondering if the incompatibility with some phones is the reason that Fly isn’t availible via the Play Store any more. I know that Go4 was and I think that when I bought my Mini 2, you could d/l Fly from the Play Store. Possibly later versions aren’t programmed in accordance with Android guidlines and that is why it isn’t availible there. Anyway v1.4.2 is working great for me on the Mini 2 so I’ll just stick with it.

I wish that were the reason :blush:

This is the issue.

DJI perform “background updates” on the app instead of submitting the app to Google for a code review like 99% of other app developers.

God only knows what else the Android version is doing in the background that they don’t want Google to know about. This still has all sorts of alarm bells ringing in my head. It could be harvesting all sorts of personal data from your device for all we know :confused:

1 Like

dji are aware that the samsung s21/ s21 ultra have issues and are trying to get a fix out for them, with no video feed etc so for now do not be using a samsung s21 phone :slight_smile:

1.4.2 has been working fine for me on the huwai tab8 so far. Hopefully dji get their fingers out and get it all sorted as I also have an S21 that I’d like to be able to use

If you use an APP like PCAPdroid you can see all the external connections the DJIFly APP creates on startup.

I’ve yet to run the PCAP APP while the DJIFly APP is in use.

1 Like

This seems depressingly familiar…

I honestly thought my drone was faulty… (I didn’t connect my updating of the Fly app with the problem as I didn’t fly it straight after the update)

I’m only glad that I asked about it here and got the nod to roll back. it is eminently usable again now.

I’m not getting much feedback from DJI forum do far… apart from try flying away from built up areas.

I think the feedback in this thread is probably spot on…

I don’t get it though that Android as an OS has the larger customer base (and they restrict the operation to relatively few devices models…) compared to Apple yet they seemingly have no ‘real’ issues.

Still a usable drone is a good drone LOL

Also remember to switch airplane mode on, you don’t want any possibility of interference from Bluetooth and wifi

Have the same problem with my galaxy s21 ultra. Screen is either black or just frozen.
Says 21 on the list but I’m guessing it’s not the ultra.
Using my old huawei mate p20 Pro and works fine.

It’s worth trying version 1.4.2 too see if that works

1 Like