NoLimitDronez worth the £££?


#21

A quick response from NLD via Twitter … yes, still need to roll back.

Hmmm … switching back and forward between “built in pano” / “no NFZ” might be a pain too much.

I must have a go at doing manual pano … and I don’t need to have NFZs killed all the time … just occasionally.

Edit: There was also a hint that NFZs might soon be switchable in the current version … " … who knows what the nearest future brings … :wink: "


#22

Miserable day so decided to give this a try.

One of the conditions is IOS go4 app must be 4.1.3 or lower.
Managed to get that done.

Now flashing 01.03.0700 firmware, taking forever. Guessing I’ll need to do the controller as well.

It’s got an option to modify go4 APK for android but guessing will need to change config file manually on IOS.

Removing height limit will be main goal for mountain flights but what’s some other parameters worth changing?

Is 0700 firmware a good starting point. I really have no clue.
@PingSpike @Cobblers


#23

Wotcha Callum… this is addictive stuff eh? :smiley:

I spent the rainy weekend rooting my Mavic and deleting stuff I probably should be deleting :stuck_out_tongue:

I’ve listed some common parameters at the bottom of this post. There may be others but they’re probably the most popular.

I’ve been playing some more with the custom building of the GO4 app and my current CrystalSky GO4 built in app is only v4.1.3 (running ‘Here maps’) but I’m now running v4.1.22 on there at the same time (which gives me Google Satellite Maps back!). I’m probably finished now, it does everything I need it to and more importantly, it doesn’t do the things I don’t want it to :hear_no_evil: :see_no_evil: :speak_no_evil:

Yup, the .700 is considered by many to be the Bret Hart of the firmware world :slight_smile:


#24

This is turning into a nightmare.

Flashed AC no problems. Problems detecting RC and when it did says flash complete but now when reconnect does not show firmware and Assistant 2 will not touch it.

Downloading DUMLdore, hopefully that can come to the rescue.


#25

Just in case:


#26

I’ve got assistant to see the RC now but shows no firmware. I can’t even rest it to factory settings.

Flashed again with DUMLdore but same result.

Rc is behaving normally, just constant saying connecting.

Tried binding to no avail.

Flashing mavic directly through DUMLdore and see if that works.

I’m night shift tonight so can only spend another hour on it. Heads splitting and feel like throwing it off a wall lol.

Curreny


#27

Flashing mavic directly through DUMLdore at 80% and it’s reconnected to RC.

Was mavic firmware installed by NLD mod that caused the problem.

Thank God!!!

What I’ve learned is flash firmware directly through dumldore!!


#28

Blimey mate! Bit of a nightmare eh?

I went the DUMLdore route too, albeit some time ago now, the process probably hasn’t changed that much.

Glad you’re back up and running though!

So the bird and remote are now both on .700 ?


#29

Yes both on .700 now and 4.1.3 go4 app with config file applied.

Strange as NLD flashed and was reporting drone as .700 but would just not connect.

I’d say dumbldore is probably easier to use. That and dankdrone to get the firmware.

Made a few tweaks in NLD, mainly removing altitude limit for mountain flying.

Go app still shows 500m limit. Does it just go past this regardless?

Android seems to have more possibilities for modding like creating custom APK as you have.

Will try on my s8 but ultimately would like to get a crystal sky at some point.


#30

After playing about with NLD mod in response to original question.

I don’t think it’s worth it.

I wouldn’t use it for downgrading as encountered issues and DUMLdore is easier and works.

It’s handy for quickly changing parameters but you can do that in older version of assistant, just not with a nice UI. You need an old version of assistant to use NLD anyway.

For IOS you need to downgrade your app to 4.1.3 and it has no options to modify for FCC etc. Downgrading is a bit of a pain.

For android you can create a custom APK in the app with FCC mode etc, no fly zone disable, no wind warnings etc but you can’t select them individually, it’s all or nothing.

Basically you can do everything for free with a little research.

What annoyed me is they advertised 24hr live chat for technical assistance.

When I had problems live chat was unavailable, and had to email, will see how long it takes to get a response.


#31

They got back to me.

Hi!
You don’t need to downgrade the RC, and can leave it on the higher firmware level. There are no issues in doing this, as the firmware for the RC doesn’t need to match the firmware of the Mavic Pro. I leave my RC on the latest firmware.
We are aware of this issue, and it will be addresses in the next release.

Your NLD Support Team,
Cheers

  • Quad808 - fly safe!

So the support is there.

For £20 can’t really complain


#32

Good to know @callum :+1:

As mentioned, I went the DUMLdore route too, and eventually ended up modding the app manually too.

I was surprised to see the tick boxes in the NLD app were shaded out, like you say, you can either have all GO4 app mods, or none. Whereas going the deejayeye-modder route for the app gives you a lot more flexibility - but you need to work harder at it :slight_smile:


#33

Glad I read this thread. Saved myself the money and also went DUMLdore route.
Final decider was the new video that explains it all much better, and the newer version(s) of the software needed that also make life easier (I believe from reading, never tried until today.)
No problems - all done, and updated to a modded 4.100 in about 45mins.


#34

Dave, if you’re running mixed firmware, any issues with Precision Landing?

There were reports (albeit six months ago now) of mixed modules having a knockon effect with the general consensus that RTH still works but the PL side of things doesn’t, so it lands a bit off from the original take off point.

Has that been resolved now do you know?


#35

Not certain.
Need to get out and try a precision take-off! :stuck_out_tongue:
All I know so far is it hovers in the garden.
In all the 15 months I’ve had the MP, I’ve only tried PL once … to see if it was any good.
So much of my flying is off trekking where (a) I tend not to land where I took off, and (b) the terrain is so crap it’s manual landing (or hand catching) so it’s not a priority thing for me.
Ill give it a go when I’m out some time.

Edit: Actually, after all that firmware rolling, I’ve not even recalibrated a thing. Hovered like a dream!


#36

Ok now im a bit confused. With NLD mod the highest Go4 you could have on IOS was 4.1.3.

Not sure the reason as it does not change the app in any way.

NLD mod is just a GUI for changing parameters with DUMLdore integrated for firmware.

If I upgrade to modded 4.100 will I need to stay on 4.1.3 and defeat the purpose of obtaining newest features.

Can I upgrade to 4.1.12 which was last version config files worked.

Or I could upgrade to latest go4 for all features but no way of forcing FCC mode.

IOS was once the way to go for DJI but has quickly become a curse.

Really need to look into this more.


#37

So far, Modded 4.100 and latest Android Go4 (4.2.8) is working for me.
Not bothered with FCC, at all.
I’d try it without changing your current Go4 and see where you’re at.
… or change to Android … after all, everything that happens inside the MP is Android. :stuck_out_tongue:


#38

I might change to android.

I’m not an apple fan but bought the IPad mini 4 back when GO4 was buggy as hell on android and I kept getting disconnects.

IPad is completely stable on all versions but your just so limited if you want to do anything out of the norm.

Ok, I have a plan.

Upgrade to modded 4.100.

Leave IPad on 4.0.3 with FCC config. That can be my normal flying device. 90% of my flying is manual anyway.

Put a modified version of GO4 on my S8 and I can use that if I want to use quickshots, pano’s or any other newer features.

Best of both worlds.

Wish I could stop over thinking and reasearching things, slowly driving myself insane.


#39

I’m way ahead of you on that … I was born insane! :wink:


#40

I can confirm that the Pano mode still works with my Modded 4.100 and Android Go4 4.2.8