NoLimitDronez worth the £££?


#41

One annoying thing with where I’m at … whilst the MP doesn’t take over and land, because it’s in an NFZ … you do get associated warnings in your Go4 app that you are.
Funnily, these only appear after take-off … even tho the controller is displaying NFZ before take-off.
In a way … I like this situation.
Where I live I know about the NFZ and won’t be flying above minimum hover height (in the garden) just to check things.
But, at least it will still correctly warn me whenever I am in any of the DJI NFZs if I’m somewhere in another part of the world.


#42

One of my modded apps has the NFZ database completely removed from the app too, so I get no DJI 50 bloody mile wide circles on the map at all - nothing but pure silence. It’s not out in the public domain yet which is why I’ve not discussed the details. I’ll post about it in the future when I can.

I’m not sure if NLD actually pulls the entire database out or just masks the fact that you’re within an NFZ?

This patch came out last week for deejayeye-modder which works on 4.1.22 : https://github.com/Bin4ry/deejayeye-modder/blob/master/patches/4.1.22-3028592/removeNfzUpdate.patch

I’ve not tried it yet but it should suppress the NFZ popups and warnings. It won’t stop the big red banner in the top left of the screen, the only way to cure that is complete NFZ database removal from the app too (again, unless NLD actually does that too? I’ve not tried).


#43

I’m not NLDing, anyway … these threads get a bit crossed over.
I think NLD will, as you suggest, only get me to roughly where I am … except I’m less poor. :stuck_out_tongue:
Actually, I have more confidence in the DUMLdore/Dankdowloader route, anyway. I’d genuinely recommend people save their money.

The number of times I’m going to see NFZs away from home are so few I’m not over fussed.

Indeed, the number of times I’m going to fly in the garden is very few.
I’m a PPL pilot (lapsed, unfortunately) … so I’m very respectful of the runway just 300m away.

… unless I see a Spit coming in to beat up the airfield … which, as their birthplace, they often do.
I knew they were about this day, when I was on my roof doing some chimney stack re-pointing … :stuck_out_tongue:


#44

Looks like you’ve done a bit of research for FCC mode for iOS. I’m currently on the 4.1.18 version of the app. Could you point me to a tutorial/video of how to get FCC mode?

Thanks


#45

Hi the only way I know is to downgrade your app then apply a config file.

Trickiest part is downgrading the app. You will need an older version of iTunes and follow this guide closely. I’m on 4.0.3 with IOS. I’ve read 4.1.12 is the last that worked but 4.0.3 seemed to be popular.

IOS rollback

Once you are on a lower IOS, you need to add a config file. This is the simple part. Again you need an older ITunes version but follow this guide and that should be you done.

FCC config file

I used Windows to do the above but the guide also shows steps for mac.

If there’s anything your not sure about let me know and I’ll try to help.


#46

A little tip not mentioned in the guide to a problem that had me scratching my head for a few hours.

It talks of disabling 2 factor authentication on your Apple ID. Reason for this is that the older version of ITunes you will be using does not have the option to enter your verification code sent to you by SMS.

If you created your Apple account on a recent IOS it’s impossible to disable 2 factor authentication.

Solution is to enter your email and password and you will receive the pin by SMS but login will fail.

Login again but this time put the pin number directly after your password.


#47

I wouldn’t have to downgrade though would I? 4.1.3 is a version after the one I have, right?


#48

Just realised it’s 4.0.3 LOL!


#49

Ok I choose the easy option and was the £20 worth paying after flight test I have to say a defiantly yes.
Years ago I would have spent hours and stayed up all night and go to work tired, I’m now much older and get brain ache over the most simplest of tasks lol.
I paid then download DJI Assistant 2 version 1.1.2 and NLDApp, first thing I did was create a new patched NLD Go 4.1.3 to replace the DJI GO 4 APP on my tablet ran it and confirmed FCC MODE, I made sure I delete everything related to my original DJI assistant 2 which I used to use on my old Mavic pro and hack. Installed the two programs ran the two side by side but then clicked and I rolled my Mavic Pro firmware back to .700 then applied Flight Controller Settings, max altitude limit, No Flight Zone and few others slightly changed like speed.

When first trying to create patches or downgrade firmware I notice it would take a long time maybe freeze or not responding, I have very fast internet connection but I found switching off Wi-Fi and using my mobile phone as a 4G hotspot was perfect and much faster and without errors. So maybe if you’re using this or Dumldore route try hotspot instead.

Flight tests see if all hacks working,
I got Magnetic Field Interference. Exit P-GPS Mode; Yaw Error, this was due to me having a tracker at the rear so did the compass and all working perfectly.
Below is my original drone results but on my new drone with forced FCC it doubled this and could have gone further before I had to return due to starting off with 70% battery in first place.
Outside town boundary.
with config file 1250m
without config file weak signal at 1110m
inside town boundary
with config file weak signal at 874m
without config file 596m
had 33% left so went up and up until I reached 1,710.0ft then decided that’s enough after cancelling return home warning twice but as I’m not getting the normal messages about wind for example, but I did notice it does take quite a long time to come down and uses defiantly a lot more % dropping that’s for sure.

I then took my drone to middle of nowhere near the southern border and kept getting Compass Error And Magnetic Field Interference and did not matter how much I tried recalibrating the compass but still error, removed tracker and error gone, strange as it worked in the town, now fitted tracker to side away from rear compass/GPS module and nice flight no loss of signal or stuttering which happened in the pass.


#50

Interesting to see the issues something as innocent sounding as a tracker can cause eh?

Confused by this part… you confirmed FCC or the app confirmed it was in FCC mode?

If you, then how did you confirm it?

If the app, how did the app confirm it?

I’ve never seen any FCC/CE dialogue boxes :thinking:

The guys at NLD are bringing out a new app soon, completely re-written from the ground up, and does not require DJI Assistant to even be installed. You’ll be eligible for a free upgrade too :+1:

Glad you’re sorted @ziceman :wink:


#51

While creating the NLD GO app you can select,

force FCC over EC mode
remove NFZ
offline login
remove forced firmware and apk upgrade
remove online presence on dji server
remove google analytics and api

this is a snap shot from a youtube video which is exactly like mine looks
fcc

I also like the fact i login anonymously on the app.


#52

Have you retained the ability to create Panoramas?


#53

i cannot recall seeing any when doing some camera settings, i will look into it, in the mean time ive sent a ticket asking about panorama as they might get back quicker to me before getting back home.


#54

I don’t see any of those options in my GO4, is this a Spark-only setting?

@callum - Seen these settings in your modded apps mate?


#55

I don’t see it on my app 4.1.3 or 4.1.22 but I’m not connected to drone.

What drone are we talking about?

5GHZ band on the mavic pro is only used for direct connection to phone with no controller. Occusync is 2,4GHz

Spark and Air would use 2.4 and 5GHZ being wifi.


#56

Weird… Confused now…

If I launch a NLD 4.1.3 I get an extra icon in my menu, as per that screen shot from @ziceman - And it’s set to 5G (Mavic Pro), again as per that screen shot he posted.

If I launch a deejayeye-modded 4.1.22 that ‘WiFi’ icon simply doesn’t exist.

Similarly, if I launch the standard DJI GO4 (whatever current version is) that WiFi icon isn’t there either.

If I then go back in to the NLD 4.1.3 then the 5G option is still selected.

I was unsure if I was running in FCC before… now I have absolutely no idea WTF is going on :rofl:


#57

Just checked again on 4.1.3 IOS, the option is channel mode automatic or manual. I can’t go into manual settings as not connected.

Android must be different. I don’t have an android NLD app to check anymore.

I think it’s just an option that’s been removed over the firmware revisions.

Like I said the Mavic pro controller dosent even have a 5GHz transmitter.

That option is for direct connection, drone to phone (wifi), not occusync. 5GHz was always the default if you put the mavic into Wi-Fi mode and connect that way.

Not sure how any of this is relevant to FCC?


#58

I loaded up 4.1.3 and sure enough, the options are there so your theory is correct, the 2.4Ghz / 5Ghz option has definitely been removed on later GO4 versions.

Nope, me neither now :rofl:

I was looking for a way to confirm that FCC mode is actually on / enabled.

As I suspect it’s not actually on…

But I had no idea how to confirm or determine if I’m in FCC or CE mode from within the app itself?!


Downgrading mavic pro platinum
#59

Been wondering myself. Think you just need to trust the modded app.

Only other things a range test in same conditions.

Don’t even need to fly it, power up somewhere and drive until it disconnects.

Power cycle everything, start modded app and repeat same route.

Should definitely give you an indication if it’s working or not.


#60

What makes you think it’s not working? Is your RC not boosted anyway?