DJI Fly - App updates and download links

Yes indeed - some are reporting its worse than 1.2.0 whilst others have said there is some improvement but not a total fix :man_shrugging: :man_shrugging:

1 Like

Android users?

Both Android and IOS :anguished: :weary:

1 Like

Just to finish the story. Managed to get out and fly properly yesterday…after 2 weeks of bad weather!

Everything seemed to work perfectly. Took a video and some stills. There have been a couple of updates during this time but I’m not sure they made a difference. Looks like the system just got itself locked up somehow, which released when I started recording a video.

I never trust auto updates, if there is an update available for an app best to delete the old version manually, do a restart, reset and all that bollocks, then get the new version from the app store of your choice (thats what I’ve found anyway)

2 Likes

Very interesting. After updating the fly app to the new version a week or so ago before flying my Air 2, I decided tonight just to plug in my Mavic mini 1. No flight intended. I was met by a message telling me to warm up the battery (unable to take off). I tried another battery which was part charged at 40%, and recieved another message telling me to charge the battery, unable to take off. So no flying without a charged battery or one that isn’t warm enough, so it seems, since that update.
My Dog does like the house Baltic though. :slightly_smiling_face:

Interesting, as the Mini 1 batteries aren’t LiPos :thinking:

I thought that. I wonder iff there is some crossover with the fly app that is intended for the mini 2 but affecting the mini 1. When I get chance I’ll connect the mini 1 up again and see what happens.

1 Like

So. Battery has to be over 50% to allow flight. No issues there, as it should be fully charged.
Previously when flying in the house, a warning would tell you about no gps signal and poor light. However you could ignore these and just take off. Now you have to unlock the drone when getting these messages. You get a load of advice to read through on your screen and the possible outcome iff you choose to click the confirm flight button. This is great for new pilots as it makes you think before doing.
It does make me wonder how far dji will go with these controls though.?

You might want to check out an Autel for your next drone :blush:

My mini 2 was at 25% today when I gave it a quick blast down to 10%

So it’s nothing to do with any update that may have been for the mini 2 then chris.
Next update may pop up the message. “Owner must buy the mini 2 to take off”. :grin:

Release notes for v1.2.2

23 December 2020


What’s New?

  • Adds a new Attitude Indicator: Learn more about your aircraft’s orientation and flight info.

  • Adds Flight Tips: View interesting aerial photography tips during scenarios such as firmware updates, taking hyperlapse shots, and when the aircraft is returning to home.

  • Adds the following supported functions for the Customizable Button on remote controller: Gimbal Follow/FPV, Camera Settings, and Exposure Lock/Unlock.

  • Fixes certain issues and optimizes overall app quality.

1 Like

Has anyone else noticed that there Air2 is flying a lot slower since update, Normally flay at around 11m per second in normal, but now down to 7m per second ? and was not windy ?

1 Like

I’ve not updated yet as doesn’t seem to be available on playstore yet

Direct download link, just for you @SirGunner

DJI Fly

1 Like

Thanks Rich appreciate it mate :+1:t2:

1 Like

I typed everything below over a 10 minute period while trying to get my O5 working the version. I’d been going for about 15 minutes when I typed the last line. Take this as a warning that you need to update well before flying…

Installed 1.2.2 from the direct link onto my OnePlus 5, Android 10. The app worked perfectly before, now it runs like a dog. I have also installed the app on a Xiaomi Mi Note 10, Android 10. Both installation processes exactly the same.

On the Mi, all looks well and runs without problem, flight logs visible immediately. The O5 app runs like a dog and the flight logs have gone. Seems fine if I launch and go into Profile, except for the lack of logs, but once you go back to the main screen it hangs for about a minute with Android asking if I want to wait or kill. If I wait it comes back to life, go into a main screen option and it’s OK, back to main screen and hangs again for a while.

Ooh, my logs have finally appeared and the app is running OK.

Oh ****, after a break the O5 is doing the same again. Flight logs gone, Android asking if I want to wait or kill the app, etc. They’ve either increased the base processing power needed for the app or an issue with the O5 which is still listed as compatible with 1.2.2.

A bit more testing and it seems the issue is when I go back to the main screen from Profile, that’s when it hangs. I can go into and back out of all the other options with no problems.

Not sure if I want to fly with the O5.

Is the Fly app the only app you’re running on the phone?