First flight

Ok, not exactly true…i had a cheeky 5 minutes in the back field last night but didnt get to fly too much as it was getting dark.

So i went out this morning. It didnt go brilliantly :slightly_frowning_face:

I spent the first battery flying the drone close to the ground, just to familiarise myself with the controls. I had a blast, i really enjoyed it. It was a bit windy, so i kept it low - i absolutely $hit myself when it decided to “return home” though! It slowly gained height (10 times more than id flown it) then started flying towards my direction. I was impressed that it managed to touch down about a foot away from where i was stood.

So, feeling charged by this i decided to venture a bit further. I changed the battery first then went about reconnecting the drone. This is where i first encountered some problems. The drone turned on, the remote turned on, but the phone wouldnt connect. I have it plugged in via the small usb port on the left hand side. I restarted the Go4 app, restarted the controller, restarted the drone. Still no joy. I turned the drone off, the controller off, the phone off and went through the start up procedure again - still no joy connecting (blank screen, no vid feed & not connected displayed on the top left corner of phone screen). After about 10 mins of repeating this procedure, changing the order of reset & connect for each item each time, i finally got a message on the phone saying “incompatible firmware” or something along those lines? I’d only flown it 15 minutes before hand without a problem though? So i went through the update process, which worked. I got about 10 minutes of flight, but the wind warning started to kick in, so i flew the drone back towards me. When it was close enough i thought id try out the active follow feature. I had it focus on me (the big bloke with the red puffer jacket on), it followed me walking for about 10 seconds, then the video feed froze, it flashed up that it was now disconnected & the drone started to fly on its own for a few seconds. I frantically pressed the pause button, tried quickly resetting the app & pulling down on the left stick. In hindsight, Im pretty sure it was going through the return home procedure, but i must say was panicking a bit at this point. So i packed up and returned home.

On my return i found that it hadnt taken any photos? Id pressed the photo button a fair few times during the flight too! It took some footage, on viewing it, the quality isnt fantastic. I have it set to 4k @ 30fps. It looks a tad washed out and not very crisp. I understand its an overcast day, but on the whole, not what id expected.

Im sat charging the batteries (on the powerextra) and waiting to go fly it again. Im hoping that the 2nd flight will be better.

So my 2 key points here are, flakey connection between the phone app and the drone. I tried using my old Google Nexus 6P for this. Anyone any ideas how to rectify this? Is it a common occurrence? Or am i doing something wrong?.
Secondly, the photos not “taking” and the footage looking quite bland for 4K.

Any help here would be greatly appreciated.


Generally the cable that comes with the mavic is not the best. Also connecting to the bottom USB port rather than the side one seems to fair a lot better connection wise.

With regards to footage, what picture setting do you have it set to?

Washed out seems to indicate you have it set to D-Log or D-Cinestyle maybe? Those styles will look washed out until they are colour graded but do tend to give better depth in the highlights shadows to work with.

1 Like

As above.

Use the bottom usb port and a high quality micro usb cable.

As for colour, if you don’t plan on colour grading set your colour profile to normal, some people also prefer vivid.

Your camera settings may be at default 0,0,0 (sharpness, contrast, saturation).

Try 1,0,0 to improve sharpness or 1,0,1 for better sharpness and saturation.

It’s trial and error to suit your taste, bit frustrating at first but once you get your ideal settings your laughing.

Nice one,

Cheers for the advice. Im throwing some beans n toast down my neck as quick as possible, then its of out flying again!

That powerextra charger is fast!

I’ll have a monkey about with those settings and find the best usb lead i can (usb A to C might be a bit thin on the ground in my house at the moment!)

I’ll repoert back later - big thanks

I think I might know what’s happened here.

The batteries in the Mavic are ‘intelligent’. At a guess, you updated the firmware on your remote, your Mavic and the battery that was in the Mavic at the time.

It sounds like you also need to update the firmware in each of your other batteries too, which will prevent mismatch warnings.

And what’s happened here is that you were recording a video :slight_smile:

You need to stop the video, switch to camera/photo mode, take some pics, then start your video recording again :+1:

And as per above, the quality of the USB cable makes a world of difference. I’d recommend anything made by Anker :+1:

1 Like

Ps. Congrats on the first proper flight :smiley:


Are you looking for the photos on the SD card or the Go4 cache on your phone? Ditto, are you viewing the video off the card or on your phone?

I worked out why there were no photos - i was tapping the screen for focus and thought it was taking pictures. Thats sorted that issue!
I tried using the back usb and connected via a USB A to USB C wire which came with my Nexus. Its the only one i have tbh. It is obviously connected as it shows it charging on the battery icon on the phone, but it doesnt show any connection in the GO 4 app?! I tried again & again with no joy. I eventually went back to the standard side connection supplied, it worked, to a point. I got 3 disconnections and 2 times when the screen went completely black and was unresponsive. This obviously isnt inspiring confidence.
I tried a couple of different colour settings, which made a bit of difference. To be honest though, i was more concerned/scared of the loss of connection to worry about photos and film!

I enjoyed it, but unfortunately the enjoyment was marred by the connection issue. Not sure how long i can keep this going if it continues to disconnect - i cant fly in constant fear of losing the drone!!


That’s strange you couldn’t connect with nexus cable.
If the cable is well used the data side of it may be faulty.
Also unplug the side connection when your trying.

Read a few reports of GO4 crashing a lot with 6P but seems to be better with android 8. Are you on Oreo update already?

Are there any power settings on your phone? blank screen after x seconds etc, DJiGo4 tries to put my OnePlus3t into gaming mode?

1 Like

The cable is only ever used as a secondary cable for charging my pixel 2xl, so its in pretty good nic. I unplugged the side usb just incase there was conflict also - it made no difference. You’d think that flagship android devices would be top of the compatibility list after iOS.

No other ower settings or conflicts i can find.

So, its either bite the bullet and pay out more money for an ipad mini - or is it worth going for the crystalsky to ensure no incompatibility issues? Anyone got a crystalsky that can feedback honestly? If i get a crytalsky it can be paired with the future purchase of an Osmo, seamlessly. Which is one consolation.

Or i send it back and get a Spark & an Osmo for the same price.

I’d like to keep it, but im literally $hitting myself each flight. I just want to be able to fly and enjoy, without the fear!!

I had the same issues with my S8 at first. Felt same as you and bought a refurbished iPad mini 4 off Argos eBay outlet. Think it was £220.

It has been flawless, not one issue.

Crystalsky is probably the best experience you can get but I just couldn’t justify it at the time after spending so much on the mavic.
Good purchase if you can afford it. @PingSpike and few others have them and can give you advice if that’s the route you want to go.

I wouldn’t bother with the spark for now to be honest mate. Image quality or range nothing to mavic.

1 Like

Cheers Callum,

Yeah, feel a bit flattened to be honest. Chuck more money at it til it works or give up! Neither option is ideal.

I was after an Osmo+, so the ability to use a crystalsky with both - flawlessly (if that is possible) would give me piece of mind. I have 2017 ipads that i use for work, but they dont have cellular - which, as far as i understand, i will need if i want to use "active follow. Theyre also quite big. I want to take the gear out biking every now and then, so it cant be massive.

My iPad doesn’t have cellular. Basically it has no GPS so I can’t set homepoint on the fly to where the controller is, I don’t think I’d trust that anyway.

Also missing out on “follow me” which I would probably never use but active track etc works without GPS.

It’s rubbish you need to buy a new device. I’m scartching my head at why you can connect with side port but not bottom one. Only thing I can think of is the cable to be honest.

I’d be tempted to buy a new cable before splashing out and giving it another try making sure all background applications are stopped and maybe putting it in airplane mode.

I also use an ipad 4 mini without cellular.

I do have a garmin glo as a backup in case I every want to use follow me or to reset home point (say on a boat or moving vehicle)

@franco When trying to use the bottom USB port, you are disconnecting the little cable from the side port, aren’t you?

The Mavic remote controller has some weird stuff going on whereby if the small cable is plugged in the side port, it disables the bottom port :no_mouth:

Hows the glo fit to the drone?

Yeah mate, tried it connected and disconnected just in case.

Whats the deal with the crystalsky? is it bug/disconnection proof?

Not sure it does go on the Mavic, it’s a gps device for your device ie. some such as the iPad mini don’t have a built in gps chip, connect the device via BT to the glo and it gives the device gps capability.

1 Like

I wouldn’t say 100% simply because nothing is…

I’ve never suffered an app crash or a disconnect while using the CS but I dare say someone has, somewhere :slight_smile:

1 Like