Did not understand Litchi Reverse

Around the Pitons, St Lucia.

Did my first long waypoint mission with Litchi yesterday. As I was prepared for, I lost signal as the drone passed Gros Piton (mountain). It made a great video though, clip of below (will process the full res stuff when back from holiday):

However I used the “reverse” at mission end option expecting it to retrace its steps, back around the mountain. It turns out that isn’t what that does, so I believe it just hovered for a while, before initiating low battery return to home. I am amazed that I got the drone back, and am very impressed with the collision avoidance as it came straight back over the mountain - scary footage here:

3 Likes

“Reverse” should re-trace. Strange.

Good to know collision avoidance works … most of the time.
Impressive footage! :+1:x10!

Don’t forget a low sun can trigger/confuse the collision avoidance. Had a case of that the other day when flying manually … not sure what would happen in a Litchi mission.

1 Like

It does retrace, but under manual control - you have to pull back on right stick. As I was out of range that was no good.

The way to do what I wanted would be to add waypoints bringing it safely back around and then trigger RTH once there’s a clear line back.

1 Like

Ahh. Ok. I understand, now. Useful to know. I think I was under the same misapprehension.

1 Like

One of the best ‘real world’ examples of collision avoidance I’ve ever seen! Especially as your RC wasn’t even connected at that point!

I’d have been bricking it too :blush:

2 Likes

Remembered other panic detail. Landed on 7%.

1 Like

What was the total time in the air?

Airdata says 18m16s. Felt like longer, but the the wind can gust so that could explain.

The log from Litchi cuts out while the reception goes - if I can figure out how, I’ll upload the log from the drone when back. You can see where the signal is lost/recovered though:

https://app.airdata.com/main?share=FnRauR

1 Like

Here’s the full video from the mission & the scary return journey in full HD :slight_smile:

4 Likes

Even though I know you get it back, that return video is a real butt-clencher!
Some really close calls in that … and, with only forward obstacle avoidance, all it would have needed was a branch from a tree to the side to be above the MP … and it would have been so different!
Amazing! :+1:

1 Like

The other detail I failed to mention previously was it was starting to rain. Thankfully only lightly before I got it back - it can get heavy fast out there.

Now trying to figure out how to get the full flight log off the drone. Data Upload in Assistant isn’t managing to load anything.

Connected with Assitstant, you should be able to access the MP’s internal SD card and simply copy from there.
Should be able to upload to http://www.phantomhelp.com/LogViewer/Upload/ if Airdata won’t accept those files.

… and rain was almost the least of your problems. If I’m choosing between trees a mile away or it getting wet, I know which I’d go for. :wink:

Hm, it’s not mounting. Will retry when I’m not supposed to be working.

If the rain had been like this at the same time it might have been an issue :slight_smile:

Not ideal - but it would take a while before it got to places important enough for it to stop flying.

Skip to 9:00 in this clip …

Ha - I’d seen that. Impressive but I’d rather not run the same test with mine. :slight_smile:

1 Like

And I’d rather not test my MP’s forward obstacle avoidance capability quite to the extreme that you managed! LOL

1 Like

Hm, I cannot get this to work. In Assistant I go to Data Upload as instructed here (http://www.datfile.net/DatCon/retrieveV3Dat.html) but instead of showing a list the spinner doesn’t go away. No USB drive is mounted either.

The storage card doesn’t get mounted either… I’ll try a different computer.

Appears to a not uncommon problem - https://forum.dji.com/thread-124530-1-1.html - tried on two computers now :confused:

Problem A solved. “I don’t use android, I don’t need to install that driver” <- me being an idiot not realising that’s needed to talk to the drone.

Problem B - The data doesn’t appear to be there. The dates don’t seem to correspond to actual flights. I’ve pulled all the data off and had a look, but I don’t think it’s there. I saw a post suggesting the drone only stores so many logs and then stops once there’s no room left, and suggests deleting old logs - https://mavicpilots.com/threads/keeping-dats-on-the-mavic-pro-accessible.41047/ - though I’m hesitant to start messing with files on the drone directly, and in any case, that wouldn’t help getting at the log in question.